我要发帖 回复

正式会员

2

主题

24

积分

0

专家分

兴趣点(最多三项):

Unreal引擎
VR头盔

私信
发表时间 : 2018-10-23 10:17:14 | 浏览 : 181    评论 : 0
本帖最后由 longbaoyige 于 2018-10-23 01:20 PM 编辑

根据官方帮助文档https://developers.google.com/ar/develop/unreal/augmented-images/guide?hl=zh-cn指示
用官方UE4.20版本打包ARCore例子,发现HelloARUnreal能运行,并且能够打包成功。但是AugmentedImages打包失败。总是提示
LogGoogleARCoreAPI: Error: Failed to build augmented image database

经调查发现为官方版本问题,官方目前ARCore版本为1.2.0。尝试下载了GoogleArcore最新版源代码https://github.com/google-ar-unreal/UnrealEngine/tree/4.20-arcore/Engine/Plugins,使用的是ARCore1.5.0,编译完成后发现烘焙Augmented已经成功,但依然打包失败,提示缺少android相关功能。尝试复制arcore版本的GoogleARCore和GoogleARCoreService到UE4.20.3官方版本发现版本不匹配也无法使用。~~~~查看发现arcore版本为4.20.2而官方版本为UE4.20.3,所以又下载了官方的4.20.3版本https://github.com/EpicGames/UnrealEngine/releases源代码,将源代码解压,并且将4.20.2的arcore版本的GoogleARCore和GoogleARCoreService这两个插件复制到4.20.3下,编译成功。复制这两个库文件夹到官方版本下对应位置。再次打开AugmentedImages工程,提示GoogleARCore版本不匹配需要重新编译,不用怕,因为版本匹配,能够成功啦!等待编译成功,进入工程,再次打包。久违的BUILD SUCESSFUL


最近VR访客

手机版|VR开发网 ( 津ICP备18009691号 )|网站地图 统计 网安备12019202000257

GMT+8, 2019-2-16 11:28 PM

返回顶部